Jump to content
Sign in to follow this  
Rangarajan

Quicklisp Issue

Recommended Posts

Hi,

I know support for quicklisp is not expected of this forum, but in case someone has found a fix, I would appreciate the insight.

 

I installed quicklisp without any problem. But when I try to install "drakma" library (via console), I am getting this error:

--------------

? (ql:quickload "drakma")
To load "drakma":
  Load 1 ASDF system:
    drakma
; Loading "drakma"
Read error between positions 66 and 163 in /Users/Rangarajan/quicklisp/dists/quicklisp/software/usocket-0.6.3.2/backend/openmcl.lisp.
> Error: Foreign function not found: x86-darwin64::|gethostname|
> While executing: ccl::load-external-function, in process Listener-1(7).
> Type cmd-. to abort, cmd-\ for a list of available restarts.
> Type :? for other options.

---------------

 

Regards,

Rangarajan

 

Share this post


Link to post
Share on other sites

Indeed, this is not a Opusmodus issue.

 

However,

I don't see any error when loading 'drama'.

You need to install the CCL first in your home directory.

 

Then:

;;; CCL path
(setf (logical-pathname-translations "ccl") '((#P"ccl:**;*.*" #P"/Users/opusmodus/ccl/**/*.*")))

;;; Quicklisp Setup
#-quicklisp
(let ((quicklisp-init
       (merge-pathnames "quicklisp/setup.lisp"
                        (user-homedir-pathname))))
  (when (probe-file quicklisp-init)
    (load quicklisp-init)))

 

Maybe this helps:

 

Share this post


Link to post
Share on other sites

Thanks very much.

 

Obviously I had not read the quick lisp-related posts fully. I did the following and it works now:

1) Created a directory "ccl" under my user name directory

2) cd to that directory

3) svn co http://svn.clozure.com/publicsvn/openmcl//release/1.11/darwin-x86-headers64

4) In the file "Quicklisp Start.lisp" located under "~/Opusmodus/Extensions" folder, I uncommented and modified the following line:

(setf (logical-pathname-translations "ccl") '((#P"ccl:**;*.*" #P"/Users/Rangarajan/ccl/**/*.*")))

 

That is it.

 

Regards,

Rangarajan

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By torstenanders
      Dear all,
       
      After updating to a recent Opusmodus version 1.3, I ran into some errors when loading code that had been loaded and compiled before, e.g., quicklisp, quicklisp libraries, swank (the interface that allows using Emacs Slime with Opusmodus), and my own Lisp libraries. The errors I saw were rather cryptic, like the following:
       
      Error: The value "CL" is not of the expected type list.
      While executing: (:internal ccl::operation-on-all-specs ccl::%define-package), in process Listener-1(7).
       
      After exchanges with Janusz (thanks a lot for your help!) I learnt that the underlying Common Lisp version of Opusmodus had been upgraded to CCL version 1.12, and the format of compiled files (fasl files or dx64fsl files) of this version had changed.
       
      So, in case you run into similar problems, these can be fixed simply by deleting all previously compiled files (which Lisp stores if they do not change to speed up the load process), so that the Lisp compiler has to compile them again. In the folder  ~/.cache/common-lisp just delete any folders starting with ccl-, so that all compiled files in this directory are compiled again.
       
      Best,
      Torsten
    • By RST
      > Error: The function double is predefined by Opusmodus.
      > While executing: ccl::cerror-if-redefine-om, in process Opusmodus Extension Initialization(5).
      > Type cmd-/ to continue, cmd-. to abort, cmd-\ for a list of available restarts.
      > If continued: Replace the definition of double.
      > Type :? for other options.
      1 > 
       
      Recently when I start Opus Modus I get this error message.  Is there something to do?
      With thanks!
    • By Rangarajan
      Hi,
      When you click "Clear" in the Listener window, the entire text is cleared as expected, but the prompt does not appear - even if you press "Enter" many times. It comes back only after you evaluate an expression. I think that "Clear" should bring back the prompt after clearing the text.
       
      Regards,
      Rangarajan
×
×
  • Create New...