Jump to content

Recommended Posts

Hello. I am a Music Composition student at UCSD and I would love to try this wonderful looking program. However, it seems that after downloading the Trial Version and installing it, the program itself won't load (I am using OS X Yosemite and I have already altered the security settings and gave permissions to run software). The Opusmodus logo just bounces but never loads until it is ultimately unresponsive.

Any help/info would be much appreciated. 
Thanks!

Link to post
Share on other sites

Lets try this.

Go to your home directory and delete the folder Opusmodus - if you find one. This folder is create automatically by the first time you start of the application.

 

1. In Finder, Control-click or right click the icon of the Opusmodus application.

2. Select Open from the top of contextual menu that appears.

3. Click Open in the dialog box. If prompted, enter an administrator name and password.

Link to post
Share on other sites

Still not working unfortunately. There was no Opusmodus folder in my Home Directory (I'm assuming because the application hasn't had its first start yet?). Even when Opening the application from finder using right click, Opusmodus just lingers without fully booting until it stops responding.

Link to post
Share on other sites

I can report a similar experience on a MacBook Pro (Retina, Mid 2012) running OSX Yosemite.  The program doesn't launch and then I must force-quit it.  However, the demo program is running great on my desktop computer, a recent Mac Pro also running Yosemite.  Thanks for any troubleshooting suggestions (I tried various ways of opening and permission seems fine).  

Link to post
Share on other sites

Thank you for the post and successful installation on Mac Pro running Yosemite.

austinkool94, could you tell on what mac (model) you tried to make the installation? 

What OS version you are using 10.10 or 10.10.1

 

What I will make update to Opusmodus and will add a console, this way I hope we will see some kind of error message in it.

Link to post
Share on other sites

Opusmodus ver. 1.0.15670 is ready for download.

I have added AltConsole application to the system which should help us to find the problem with the installation.

 

1. Open Opusmodus

2. Look for AltConsole application in your Dock.

3. Click on it.

4. type   :b

5. then press the return key

 

Copy the content of the window and send it to me.

This way we might find the problem why you can't install the software.

Link to post
Share on other sites

here's the terminal window output of dx86cl64

 

Thanks,

 

Last login: Wed Dec 17 15:47:59 on ttys000

seg15-3:~ seg$ /Applications/Opusmodus.app/Contents/MacOS/dx86cl64 ; exit;

; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/audiotoolbox/records.cdb" does not exist, and the containing directory does not exist.

;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized. 

; While executing: CCL::CDB-OPEN, in process Initial(0).

; Warning: Interface file #P"/Users/opusmodus/ccl/om-src/trunk/cdb/darwin-x86-headers64/iokit/records.cdb" does not exist, and the containing directory does not exist.

;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized. 

; While executing: CCL::CDB-OPEN, in process Initial(0).

; Warning: Interface file #P"/Users/opusmodus/ccl/om-src/trunk/cdb/darwin-x86-headers64/security/records.cdb" does not exist, and the containing directory does not exist.

;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized. 

; While executing: CCL::CDB-OPEN, in process Initial(0).

; Warning: Interface file #P"/Users/opusmodus/ccl/om-src/trunk/cdb/darwin-x86-headers64/seescorelib-mac/records.cdb" does not exist, and the containing directory does not exist.

;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized. 

; While executing: CCL::CDB-OPEN, in process Initial(0).

; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/webkit/records.cdb" does not exist, and the containing directory does not exist.

;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized. 

; While executing: CCL::CDB-OPEN, in process Initial(0).

; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/quartz/records.cdb" does not exist, and the containing directory does not exist.

;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized. 

; While executing: CCL::CDB-OPEN, in process Initial(0).

; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/cocoa/records.cdb" does not exist, and the containing directory does not exist.

;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized. 

; While executing: CCL::CDB-OPEN, in process Initial(0).

; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/libc/records.cdb" does not exist, and the containing directory does not exist.

;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized. 

; While executing: CCL::CDB-OPEN, in process Initial(0).

Terminated: 15

logout

 

[Process completed]

Link to post
Share on other sites

The warnings from cdb-open are expected.  They are not causing the application to fail to launch.

Here are some suggestions:

You could open the /Applications/Utilities/System Information.app, choose Save... from the File menu and attach the output file here.

Maybe something there would provide a hint about what is going wrong.

Have you create a new account on your system, and trying using Opusmodus.app from the new account.

If you download Clozure CL.app from the Mac App Store, does that work?

Edited by opmo
Link to post
Share on other sites

hello,  

I tried downloading new version.  FYI, AltConsole took a very long time to launch (while the program was unresponsive). 

:b 

+ return key did not produce output

the console did state, prior to entering 

:b
received midi notification: id = :MIDI-PROPERTY-CHANGED (4)
received midi notification: id = :MIDI-SETUP-CHANGED (1)
received midi notification: id = :MIDI-PROPERTY-CHANGED (4)
received midi notification: id = :MIDI-SETUP-CHANGED (1)

I downloaded Clozure CL.app  and it launches fine.

I created a new account on my system with Admin privileges and it doesn't launch Opusmodus (behavior is the same).

The output of my system information was too big to upload on the forum (5.4 MB), so I've attached a screen shot of the hardware overview.  Perhaps I could send the larger file to you over e-mail?

I am happy that Opusmodus is running smoothly on my Desktop;  so I'm not too concerned about my laptop having difficulties - but hopefully this helps someone else too.  This laptop has seen a system migration and at least one OS upgrade...  so perhaps it has some underlying issues that might be solved with a fresh OS install. 

Best,

Link to post
Share on other sites

Thank you very much for a detailed report.

Lets see if there any error messages in Console.app

/Application/Utilities/Console maybe this will give us some useful information.

1. Open the Console app

2. Open Opusmodus app

3. Select all the dx86cl64 lines and send it to me by email - info@opusmodus.com

Thank you for your time and your help.

Edited by opmo
Link to post
Share on other sites

Hi,

I'm having exactly the same problem running the Trial version on a MacBook Pro early 2008 and Mac Pro 2008. I ran the dx86cl64 executable through dtruss. I also have system_profiler output but prefer not to attach it here, since it contains extensive info on my system. I could email it separately if needed. The last 2 lines of the output are me hitting Ctrl-C in the dx86cl64 terminal process:
11040/0x1d0f38:  sigreturn(0x7FFF5FBFEFB0, 0x1E, 0x264000)         = 0 Err#-2
11040/0x1d0f38:  sigreturn(0x7FFF5FBFEFB0, 0x1E, 0x264000)         = 0 Err#-2

Update: The output is too long for the post. Is there a way I can email it to you?

I hope this helps!

Paul M.

Link to post
Share on other sites

Dear madrqdt, please send me the output of the Console.app to info@opusmodus.com

Howto:

 

/Application/Utilities/Console maybe this will give us some useful information.

 

1. Open the Console app

2. Open Opusmodus app

3. Select all the dx86cl64 lines and send it to me by email - info@opusmodus.com

Link to post
Share on other sites

If this is of any help, I tried replacing the dx86cl64 in Opusmodus with the one installed by the Clozure CL app downloaded for the Apple Store. Clozure CL runs if I run it as an application, and I can evauate expressions. But if I copy it into the OpusModus application in Contents/MacOS (I backed up the existing one), I get the same problem-- the app hangs when opening.

I also tried:

1. setthing the permissions to 777 in Opusmodus.app

2. Disk Utility -> System Disk -> Repair -> Repair Disk Permissions

Link to post
Share on other sites

I ran dx86cl64 from the command-line following a fresh install of Opusmodus. After hitting Ctlr-C, I was able to get some sort of backtrace:

prm-mbpro:MacOS marqrdt$ ./dx86cl64
; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/audiotoolbox/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).
; Warning: Interface file #P"/Users/opusmodus/ccl/om-src/trunk/cdb/darwin-x86-headers64/iokit/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).
; Warning: Interface file #P"/Users/opusmodus/ccl/om-src/trunk/cdb/darwin-x86-headers64/security/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).
; Warning: Interface file #P"/Users/opusmodus/ccl/om-src/trunk/cdb/darwin-x86-headers64/seescorelib-mac/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).
; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/webkit/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).
; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/quartz/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).
; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/cocoa/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).
; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/libc/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).

^C> Break: interrupt signal
> While executing: CCL::|-[NSApplication lispInterrupt:]|, in process Initial(0).
> Type :GO to continue, :POP to abort, :R for a list of available restarts.
> If continued: Return from BREAK.
> Type :? for other options.
1 > :b
 (747DE0) : 0 (FUNCALL #'#<CCL::|-[NSApplication lispInterrupt:]|> 17591849974438) 685
 (747E48) : 1 (%PASCAL-FUNCTIONS% 10 17591849974438) 365
 (747F00) : 2 (FUNCALL #'#<Anonymous Function #x3000019908DF> #<CCL-APPLICATION <CCLApplication: 0x2454fba0> (#x2454FBA0)> #S(CCL::OBJC-SELECTOR :NAME "run" :%SEL #<A Foreign Pointer #x7FFF8FDACFC4>)) 173
 (747F20) : 3 (FUNCALL #'#<(:OBJC-DISPATCH NEXTSTEP-FUNCTIONS:|run|)> ???) 541
 (747F58) : 4 (EVENT-LOOP NIL) 421
 (747FA8) : 5 (FUNCALL #'#<(:INTERNAL GUI::COCOA-STARTUP GUI::START-COCOA-IDE)>) 853
1 > :b
 (747DE0) : 0 (FUNCALL #'#<CCL::|-[NSApplication lispInterrupt:]|> 17591849974438) 685
 (747E48) : 1 (%PASCAL-FUNCTIONS% 10 17591849974438) 365
 (747F00) : 2 (FUNCALL #'#<Anonymous Function #x3000019908DF> #<CCL-APPLICATION <CCLApplication: 0x2454fba0> (#x2454FBA0)> #S(CCL::OBJC-SELECTOR :NAME "run" :%SEL #<A Foreign Pointer #x7FFF8FDACFC4>)) 173
 (747F20) : 3 (FUNCALL #'#<(:OBJC-DISPATCH NEXTSTEP-FUNCTIONS:|run|)> ???) 541
 (747F58) : 4 (EVENT-LOOP NIL) 421
 (747FA8) : 5 (FUNCALL #'#<(:INTERNAL GUI::COCOA-STARTUP GUI::START-COCOA-IDE)>) 853
1 >

 

Link to post
Share on other sites

Pardon if this is a repost, as my original post seems to have disappeared. I was able to download and install the latest Trial version on my MacBook Pro. I ran dx86cl64 from a command prompt. I ws able to get a console hitting Ctlr-C and post a backtrace:

vajra:MacOS marqrdt$ ./dx86cl64
; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/audiotoolbox/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).
; Warning: Interface file #P"/Users/opusmodus/ccl/om-src/trunk/cdb/darwin-x86-headers64/iokit/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).
; Warning: Interface file #P"/Users/opusmodus/ccl/om-src/trunk/cdb/darwin-x86-headers64/security/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).
; Warning: Interface file #P"/Users/opusmodus/ccl/om-src/trunk/cdb/darwin-x86-headers64/seescorelib-mac/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).
; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/webkit/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).
; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/quartz/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).
; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/cocoa/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).
; Warning: Interface file #P"/Applications/Opusmodus.app/Contents/Resources/ccl/darwin-x86-headers64/libc/records.cdb" does not exist, and the containing directory does not exist.
;          This may mean that that the "ccl:" logical-pathname host has not been properly initialized.
; While executing: CCL::CDB-OPEN, in process Initial(0).

^C> Break: interrupt signal
> While executing: CCL::|-[NSApplication lispInterrupt:]|, in process Initial(0).
> Type :GO to continue, :POP to abort, :R for a list of available restarts.
> If continued: Return from BREAK.
> Type :? for other options.
1 > :b
 (747DE0) : 0 (FUNCALL #'#<CCL::|-[NSApplication lispInterrupt:]|> 17591849974438) 685
 (747E48) : 1 (%PASCAL-FUNCTIONS% 10 17591849974438) 365
 (747F00) : 2 (FUNCALL #'#<Anonymous Function #x3000019908DF> #<CCL-APPLICATION <CCLApplication: 0x2454fba0> (#x2454FBA0)> #S(CCL::OBJC-SELECTOR :NAME "run" :%SEL #<A Foreign Pointer #x7FFF8FDACFC4>)) 173
 (747F20) : 3 (FUNCALL #'#<(:OBJC-DISPATCH NEXTSTEP-FUNCTIONS:|run|)> ???) 541
 (747F58) : 4 (EVENT-LOOP NIL) 421
 (747FA8) : 5 (FUNCALL #'#<(:INTERNAL GUI::COCOA-STARTUP GUI::START-COCOA-IDE)>) 853
1 > :b
 (747DE0) : 0 (FUNCALL #'#<CCL::|-[NSApplication lispInterrupt:]|> 17591849974438) 685
 (747E48) : 1 (%PASCAL-FUNCTIONS% 10 17591849974438) 365
 (747F00) : 2 (FUNCALL #'#<Anonymous Function #x3000019908DF> #<CCL-APPLICATION <CCLApplication: 0x2454fba0> (#x2454FBA0)> #S(CCL::OBJC-SELECTOR :NAME "run" :%SEL #<A Foreign Pointer #x7FFF8FDACFC4>)) 173
 (747F20) : 3 (FUNCALL #'#<(:OBJC-DISPATCH NEXTSTEP-FUNCTIONS:|run|)> ???) 541
 (747F58) : 4 (EVENT-LOOP NIL) 421
 (747FA8) : 5 (FUNCALL #'#<(:INTERNAL GUI::COCOA-STARTUP GUI::START-COCOA-IDE)>) 853
1 >
 

Link to post
Share on other sites

I really don't have any great ideas about what is causing this.

1. One guess at the moment is to try to move "/Library/Audio/Plug-Ins/HAL/Digidesign CoreAudio.plugin" somewhere else temporarily and see if that does anything.

2. I also still think it's worth trying to start the application from a new account that has never been used.  At least make sure that "~/Library/Saved Application State/com.opusmodus.Opusmodus.savedState" doesn't exist (delete it if it does).

Just to make sure I expect that Opusmodus.app is on the hard disk somewhere, and not on a mounted disk image file :-)

Edited by opmo
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy