Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By torstenanders
      Dear all,
       
      After updating to a recent Opusmodus version 1.3, I ran into some errors when loading code that had been loaded and compiled before, e.g., quicklisp, quicklisp libraries, swank (the interface that allows using Emacs Slime with Opusmodus), and my own Lisp libraries. The errors I saw were rather cryptic, like the following:
       
      Error: The value "CL" is not of the expected type list.
      While executing: (:internal ccl::operation-on-all-specs ccl::%define-package), in process Listener-1(7).
       
      After exchanges with Janusz (thanks a lot for your help!) I learnt that the underlying Common Lisp version of Opusmodus had been upgraded to CCL version 1.12, and the format of compiled files (fasl files or dx64fsl files) of this version had changed.
       
      So, in case you run into similar problems, these can be fixed simply by deleting all previously compiled files (which Lisp stores if they do not change to speed up the load process), so that the Lisp compiler has to compile them again. In the folder  ~/.cache/common-lisp just delete any folders starting with ccl-, so that all compiled files in this directory are compiled again.
       
      Best,
      Torsten
    • By RST
      > Error: The function double is predefined by Opusmodus.
      > While executing: ccl::cerror-if-redefine-om, in process Opusmodus Extension Initialization(5).
      > Type cmd-/ to continue, cmd-. to abort, cmd-\ for a list of available restarts.
      > If continued: Replace the definition of double.
      > Type :? for other options.
      1 > 
       
      Recently when I start Opus Modus I get this error message.  Is there something to do?
      With thanks!
    • By Rangarajan
      Hi,
      When you click "Clear" in the Listener window, the entire text is cleared as expected, but the prompt does not appear - even if you press "Enter" many times. It comes back only after you evaluate an expression. I think that "Clear" should bring back the prompt after clearing the text.
       
      Regards,
      Rangarajan
×
×
  • Create New...