Jump to content

MIDI output preferences don't seem to work


Recommended Posts

Hi. I am trying to route Opusmodus MIDI output to either an external synth via a MOTU MTP AV, or internally to NI Kontakt 5.

I have tried various different port settings in the Audition Preferences panel of Opusmodus, but no matter what port I select,

MIDI only goes to cable 1 of the MTP and nowhere else. It will not go to Kontakt even when the output name in Kontakt matches

the output name in Opusmodus.

I have verified that other sequencer programs on my machine  are routing MIDI correctly.

This is with a 2013 Mac Pro running OSX 10.9.5, and Opusmodus 1.0.15669.

Is this a known problem?

Link to post
Share on other sites

There are no known problems with Opusmodus MIDI routing.

First check you MIDI ports. Evaluate the function below:

(midi-destinations)

 The output of the function should looks something like this:

=> ((0 . "Bus 1") (1 . "Bus 2") (2 . "Bus 3")
    (3 . "Bus 4") (4 . "Session 1") (5 . "vPacarana"))

You can use one of the formats, a number or the string name.

Score example with port using a number:

(setf mat '((q a4 e a4 = q b4 trem-s)
            (e c5 trem-t s d5 trem-3s s e5 trem-x h a5 trem)
            (q a5 ff fermata)))

(def-score tremolo
    (:key-signature '(c maj)
     :time-signature '(3 4)
     :tempo 60)
  
  (inst
   :omn mat
   :port 0
   :channel 1
   :sound 'gm
   :program 'violin)
  )
Now, the same score but with port string name:
(setf mat '((q a4 e a4 = q b4 trem-s)
            (e c5 trem-t s d5 trem-3s s e5 trem-x h a5 trem)
            (q a5 ff fermata)))

(def-score tremolo
    (:key-signature '(c maj)
     :time-signature '(3 4)
     :tempo 60)
  
  (inst
   :omn mat
   :port "Bus 1"
   :channel 1
   :sound 'gm
   :program 'violin)
  )

The Port setup in Opusmodus Preferences is for Audition (snippets) only and not a general MIDI setup, Opusmodus recognize you MIDI setup automatically. 

The port number is 0-based, therefore you see number 0 for port 1.

Edited by opmo
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy