Jump to content
Sign in to follow this  
neuronsong

Timeframe to run on Catalina

Recommended Posts

I'm thinking of purchasing opusmodus and I'd like to take advantage of the current sale price. However, it is the case I am running the Catalina Beta on the laptop I'd like to use primarily to run the software. I've downloaded the trial version... but it does not seem to be working properly on Catalina. How soon do you think you'll be supporting Catalina?

Share this post


Link to post
Share on other sites

I see OpusModus 2.0 is scheduled for release soon-- I look forward to some of the new features. I've been running Catalina for  several months. I used to have two Macs, where I could have them at different versions, but no I have only one with 10.15 Catalina. It's been several months since I've been able to use OpusModus. I'd like to know:

 

1. Will there be a pre-2.0 version that will be released with compatibility with OS Catalina 10.15?

2. If so, will it be a free or paid upgrade?

3. Will 2.0 be compatible with OS Catalina 10.15 when it comes out?

 

Thanks in advance,

 

Paul M.

Edited by marqrdt
clarify question...

Share this post


Link to post
Share on other sites

Catalina 10.15 will be not supported in time of the release of ver. 2.0. CCL is trying to resolve the problem with help of Apple as far as I know. Because of many issues with Apple OS upgrades many people are still on 10.8 - 10.12.

Share this post


Link to post
Share on other sites

Just received an info:
 

Quote

Thanks mostly to Apple we've not had good news on the Mac recently, but, today we have very good news.  One can build CCL from scratch on 10.15.3 Catalina without using old tools.  Apple has fixed the assembler.

 

Good news indeed. How this will work with OM build needs to be tested.

Share this post


Link to post
Share on other sites

And care must be taken, as many of the updates released for Catalina notarization compatibility are now broken under 10.9.5. Apparently, certain combinations of code are ok, but at least as far as audio apps and plug-ins...9 out of 10 updates no longer run on my machine. I am told 10.11 is minimum, but several developers (like Zynaptiq) are able to maintain 10.9.5 compatibility...so it is possible, at least with their framework.

 

And again, my experience is mainly coming from audio plug-ins compiled for Catalina that did work previously on Mavericks, and now don't. Not sure what, if any, of this affects the compiling of code for an app like Opusmodus?

Share this post


Link to post
Share on other sites
On 2/9/2020 at 5:50 AM, opmo said:

Catalina 10.15 will be not supported in time of the release of ver. 2.0. CCL is trying to resolve the problem with help of Apple as far as I know. Because of many issues with Apple OS upgrades many people are still on 10.8 - 10.12.

I'm not upgrading and it isn't due to problems with the upgrade itself.  Lots of audio software I use isn't compatible.  Sweetwater has compiled a long list if anyone is interested: https://www.sweetwater.com/sweetcare/articles/macos-10-15-catalina-compatibility-list/

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Alain
      Catalina vs Opusmodus  = crash
       
      When will you fix this?
    • By Stoney
      I didn't look closely enough at the system requirements for V2, and have found that it doesn't open any windows on Catalina (10.15.3). I'm aware of the CCL compiler problem, but I thought that had been fixed.
       
      Is there an expectation that V2 will run on Catalina soon?
    • By opmo
      To run Opusmodus 2.0 on Catalina you need macOS 10.15.4 or higher.
×
×
  • Create New...