Jump to content
Sign in to follow this  

V1.3.24409 startup errors

Recommended Posts

I just installed V 1.3.24409, and am getting some errors on startup. The first one is an alert that says:

"Error in Hemlock command processing. There is no applicable method for the generic function: #<STANDARD-GENERIC-FUNCTION ENSURE-COMPOSER-PANE #x302001D4373F> when called with arguments: ("/Users/<my username>/Documents/Opusmodus/Extensions/Load CLM Instruments.lisp" #<OM-LAYOUT-CONTROLLER <OMLayoutController: 0x134880> (#x134880)>).


After I dismiss that, a window opens that says: Error: File #P"clm:instruments;" does not exist.
> While executing: clm-user-ins-path, in process Opusmodus Extension Initialization(6).

and then the error recovery options.


I have deleted both the ~/Documents/Opusmodus and ~/.opusmodus folders, deleted the prefs file, and searched for any other opusmodus folders, so I'm confident that it's clean. I then reinstalled the newly DL'd Opusmodus, launched it, entered my serial #, and created a new Opusmodus folder. This didn't help.


The file ~/Documents/Opusmodus/Extensions/Load CLM Instruments.lisp exists and looks unremarkable.  ~/Documents/Opusmodus/CLM/instruments exists and contains a bunch of .ins files.


Before I DL'd the new version, I launched the previous version 1.3.24303 and got that same error window complaining about not finding clm:instruments. I am unaware of anything changing on my Mac that might have broken this recently. I'm running Mojave 10.14.2 on an iMac (Retina 5K, 27-inch, Late 2014).


The Quick Start Workspace loads and plays anyway.


Any ideas about how to fix this?

Share this post

Link to post
Share on other sites

The Opusmodus folder needs to be in the user directory ~/Opusmodus and not in the ~/Documents folder.

This will fixed your error.

Share this post

Link to post
Share on other sites

I had to toss the folder and empty the trash before Opusmodus would ask to create a new Opusmodus folder, but it worked. Thanks.

Share this post

Link to post
Share on other sites

I am getting something similar but I have got the Opusmodus folder in my home directory. I get these two error messages:




Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Andy
      So I'm very happy to be exploring new snippet structure but cannot seem to define my own instrument, based on the example in the help file I did this but get errors:
      SOLVED: I had to Evaluate my Def-Inst before it would play..
    • By RST
      > Error: The function double is predefined by Opusmodus.
      > While executing: ccl::cerror-if-redefine-om, in process Opusmodus Extension Initialization(5).
      > Type cmd-/ to continue, cmd-. to abort, cmd-\ for a list of available restarts.
      > If continued: Replace the definition of double.
      > Type :? for other options.
      1 > 
      Recently when I start Opus Modus I get this error message.  Is there something to do?
      With thanks!
    • By TomTolleson
      I'm using the Version 1.2.21003.
      After I "evaluate and play" a score in a Workspace, all other score evaluate and play the first score even if I remove the file. For example if I have:
      Score A
      Score B
      and I evaluate and play Score A, when I evaluate and play Score B it plays Score A. If I remove score A, and evaluate and play score B it will play Score A (even though Score A is no longer there). If I remove all scores and evaluate and play in a blank screen, it will play score A.
      Additionally, after evaluating and playing multiple times, Opus Modus will cease to be able to evaluate and play anything. It gives me the following error:
      ? compile-score nil
      > Error: Too few arguments in call to #<Compiled-function serialize-scores #x3000015A629F>:
      >        0 arguments provided, at least 1 required.
      > While executing: serialize-scores, in process Listener-1(6).
      > Type cmd-. to abort, cmd-\ for a list of available restarts.
      > Type :? for other options.
      1 >
      Once this occurs, it will be the same for all scores.

      Any idea what's happening? Thanks,

  • Create New...