Jump to content
Sign in to follow this  
Timothy Rolls

Missing libraries and an error message on opening

Recommended Posts

I'm hoping someone on the forum can help me with this. Since the last update, on my laptop I am unable to use any of my spectral libraries I've created. The tbn-cs one that comes in the app still works, just the ones that I created are not found. I try recreating them and they seem to recreate fine, but after I restart Opusmodus, they still cannot be found. When I check my spectral-data/data and spectral-data/partials, I do see all the necessary files I have created. I think that is happening on my desktop machine, but I can't get to it right now to be sure (I think it was on the desktop that I first found my libraries not being found). However, on both machines, when I first start Opusmodus, I get the following error: 

> Error: The function double is predefined by Opusmodus.
> While executing: ccl::cerror-if-redefine-om, in process Opusmodus Extension Initialization(5).
> Type cmd-/ to continue, cmd-. to abort, cmd-\ for a list of available restarts.
> If continued: Replace the definition of double.
> Type :? for other options.

 

Afterwards, everything not related to my spectral libraries has seemed to run fine. 

I have not created any extensions, and I cannot find in any of my work where I might have tried to define something as double. 

I've tried reinstalling Opusmodus and it is not changing anything. 

 

Does anyone have any ideas short of reinstalling OSX? I suppose that's a possibility, but I don't want to have to try that till there is no other choice. Thanks. 

 

Regards,

Tim

Share this post


Link to post
Share on other sites

Please go to the Opusmodus Extension folder and remove the function 'double' form the 'Source Code.opmo'. This should fix the problem.

If you get massage like:

 

> Error: The function double is predefined by Opusmodus.

 

it means you are using a function name (your own) which is already part of the Opusmodus System.

 

Share this post


Link to post
Share on other sites

Thanks, Janusz. That seems to have also fixed the other problem with my spectral libraries as well. Although, I am a bit confused because I don't ever remember creating a function, let alone one called double, since it seems to be a reserved keyword in so many languages. Anyway, thanks for the help on that. I'm up and running again.

 

Best,

Tim

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By torstenanders
      Dear all,
       
      After updating to a recent Opusmodus version 1.3, I ran into some errors when loading code that had been loaded and compiled before, e.g., quicklisp, quicklisp libraries, swank (the interface that allows using Emacs Slime with Opusmodus), and my own Lisp libraries. The errors I saw were rather cryptic, like the following:
       
      Error: The value "CL" is not of the expected type list.
      While executing: (:internal ccl::operation-on-all-specs ccl::%define-package), in process Listener-1(7).
       
      After exchanges with Janusz (thanks a lot for your help!) I learnt that the underlying Common Lisp version of Opusmodus had been upgraded to CCL version 1.12, and the format of compiled files (fasl files or dx64fsl files) of this version had changed.
       
      So, in case you run into similar problems, these can be fixed simply by deleting all previously compiled files (which Lisp stores if they do not change to speed up the load process), so that the Lisp compiler has to compile them again. In the folder  ~/.cache/common-lisp just delete any folders starting with ccl-, so that all compiled files in this directory are compiled again.
       
      Best,
      Torsten
    • By opmo
      Please drop the file "v.aiff" into the ~/Opusmodus/Media/Audio directory.
      This file is a part of one of the CLM examples.
       
      soundfile: v.aiff
       
    • By hujairi
      Hi,

      Forgive me for these simple questions, but I'm curious to know what's the best way to display all the libraries I have?
       
      For example, I'm now trying to build new libraries that includes ambituses of custom-built instruments I will use, rhythmic patterns I am developing, and modes/scales I will be using. 
       
      I have the following questions:
       
      1. I'm trying to understand the difference between library, def-library, and create-library. I am particularly interested in better understanding def-library and create-library. Are the two functions very different?
       
      2. If I want to see all my rhythm libraries, for example, how can I see what I've already got on my computer?
       
      Many thanks.
×
×
  • Create New...